01-复杂度2 Maximum Subsequence Sum

Problem Definition

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Submission

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include <cstdio>
#include <vector>

using namespace std;

int main()
{
int k, tmp;
long long sum = 0;
long long max = -1;

scanf("%d", &k);
int begin = 0;
int end = k - 1;
vector<int> vec(k);
for (int i = 0; i < k; ++i) {
scanf("%d", &vec[i]);
}
for (int i = 0; i < k; ++i) {
sum += vec[i];
if (sum < 0) {
sum = 0;
tmp = i + 1;
} else if (sum > max) {
max = sum;
begin = tmp;
end = i;
}
}
if (max < 0) {
max = 0;
}
printf("%lld %d %d\n", max, vec[begin], vec[end]);

return 0;
}

Reflection

  1. 题目要求输出的为最大和子序列的首尾数字,一开始没注意,输出了该子串首位元素的下标
  2. 当前和小于零的时候,最大和子序列的下标应该初始化为下一个数
  3. 对于只有负数和零的情况,应该将最大和初始化为零
  4. 序列初始化时,应该将首尾下标置为数组的首尾下标,也就是将最大和子序列初始化为整个数组,而不是将其下标均置零。
  5. 认真读题很重要