1054. 求平均值 (20)

题目描述

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

提交代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include <iostream>
#include <string>
using namespace std;
int main()
{
int n, valid;
int i, j;
bool flag;
double num, sum;
string str;

cin >> n;
valid = 0;
for (i = 0; i < n; i++) {
cin >> str;
flag = true;
for (j = 0; j < str.length(); j++) {
if (!iswdigit(str[j]) && !(j == 0 && str[j] == '-' ||
str[j] == '.' && (str.length() - j >= 1 && str.length() - j <= 3))) {
flag = false;
break;
}
}
if (flag) {
num = stof(str, nullptr);
if (num >= -1000 && num <= 1000) {
sum += num;
valid++;
} else {
printf("ERROR: %s is not a legal number\n", str.c_str());
}
} else {
printf("ERROR: %s is not a legal number\n", str.c_str());
}
}
if (valid == 0) {
printf("The average of 0 numbers is Undefined\n");
} else if (valid == 1) {
printf("The average of 1 number is %.2f\n", sum);
} else {
printf("The average of %d numbers is %.2f\n", valid, sum / valid);
}

return 0;
}

个人思考

这道题有两个小细节:

  • 题目中提到:如果K为1,则输出“The average of 1 number is Y”。这里有一个单复数的区别。
  • 在最后一个测试点,有一个小数点在最后一位的小数,这种情况也应该考虑为合法输入。

参考资料