1004. 成绩排名 (20)

题目描述

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含1个测试用例,格式为

第1行:正整数
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
… … …
第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

提交代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <iostream>
using namespace std;

struct student
{
string name;
string id;
};

int main()
{
int N;
int score;
int max = 0;
int min = 100;
string name, id;
student best, worst;

cin >> N;
while (N--) {
cin >> name >> id >> score;
if (score > max) {
max = score;
best.name = name;
best.id = id;
}
if (score < min) {
min = score;
worst.name = name;
worst.id = id;
}
}

cout << best.name << " " << best.id << endl;
cout << worst.name << " " << worst.id << endl;

return 0;
}